FANDOM


If you're already familiar with NetBSD, this information may not be particulary new or useful to you.  It's not particularly Atari-specific.  I do however use this for my own reference when I install NetBSD/atari.


  1. Make sure to run through the pkgsrc configuration described in the packages section.
  2. Make sure to have previously installed apache.
  3. The latest major version of PHP available via pkgsrc at the time of this writing is 5.3. But ap-php won't install this one by default. To fix that, in /etc/mk.conf, add:
    1. PHP_VERSION_DEFAULT=53
      1. PHP 5.3 currently fails to compile on the version of gcc included with NetBSD 5.x and even 6. To fix this, add the following to ~/pkgsrc/lang/php53/Makefile:
        1. CONFIGURE_ARGS+= --disable-fileinfo
  4. cd /usr/pkgsrc/www/ap-php
  5. sudo make install
  6. make test
  7. su to root.
  8. vi /usr/pkg/etc/httpd/httpd.conf
  9. At the end of the LoadModule list, add the following:
    1. LoadModule php5_module lib/httpd/mod_php5.so
    2. AddHandler application/x-httpd-php .php
  10. Save and exit vi.
  11. vi /usr/pkg/share/httpd/htdocs/test.php
  12. Add the following HTML:
    <html>
    <head>
    <title>Test</title>
    </head>
    <body>
    <?php
    phpinfo( );
    ?>
    </body>

</html>

  1. Save and exit vi.
  2. shutdown -r now, or stop/start apache as described below.
  3. Once apache is running, from a separate machine on the network, browse to [http://[Atari]/test.php http://[Atari]/test.php].  It should show a test page from php.


Notes:

  • To start or stop apache without rebooting, use:
    • sh /etc/rc.d/apache start
    • sh /etc/rc.d/apache stop

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.